All Nik plugins 6.7 now displaying a GPU/CPU status window upon startup and then crash


A very strange problem that appeared after installing Nik 6.7…

As soon as a Nik plugin is launched, a small transparent window showing the status of the GPU and the GPU is displayed in the upper left corner of the plugin’s main window. See capture below. This happens with absolutely all Nik plugins be they launched standalone or from Photolab.

Problème Nik

In this situation, when I try to use the plugin’s Preferences menu, the Preferences dialog appears briefly and then the plugin crashes without any error message.

I don’t know from where this window is coming from (I’m still investigating this). System information below. Anyone with a similar problem ?

Thanks in advance.


Rapport Informations sur le système NVIDIA créé le : 01/31/2024 12:41:49
Nom du système : PHOTO

Version de DirectX : 12.0
Processeur graphique : NVIDIA GeForce GTX 1650
Version du pilote : 551.23
Type de pilote : DCH
Niveau de fonctionnalité Direct3D : 12_1
Noyaux CUDA : 896
Horloge principale : 1635 MHz
Débit de données mémoire : 12.00 Gbit/s
Interface de mémoire : 128 bits
Largeur de bande mémoire : 192.03 Go/s
Mémoire graphique disponible totale : 20369 Mo
Mémoire vidéo dédiée : 4096 Mo de GDDR6
Mémoire vidéo du système : 0 Mo
Mémoire du système partagée : 16273 Mo
Version BIOS vidéo :
IRQ : Not used
Bus : PCI Express x16 Gen3
ID de périphérique : 10DE 2188 88B41043
Référence : G166 0026


nvui.dll NVIDIA User Experience Driver Component
nvxdplcy.dll NVIDIA User Experience Driver Component
nvxdbat.dll NVIDIA User Experience Driver Component
nvxdapix.dll NVIDIA User Experience Driver Component
NVCPL.DLL NVIDIA User Experience Driver Component
nvCplUIR.dll 8.1.940.0 NVIDIA Control Panel
nvCplUI.exe 8.1.940.0 NVIDIA Control Panel
nvViTvSR.dll NVIDIA Video Server
nvViTvS.dll NVIDIA Video Server
nvWSSR.dll NVIDIA Workstation Server
nvWSS.dll NVIDIA Workstation Server
PhysX 09.21.0713 NVIDIA PhysX
NVCUDA64.DLL NVIDIA CUDA 12.4.74 driver
nvGameSR.dll NVIDIA 3D Settings Server
nvGameS.dll NVIDIA 3D Settings Server
nvLicensingS.dll NVIDIA Licensing Server
nvDevToolSR.dll NVIDIA Licensing Server
nvDevToolS.dll NVIDIA 3D Settings Server
nvDispSR.dll NVIDIA Display Server
nvDispS.dll NVIDIA Display Server

Problem solved but still puzzling… (after posting my initial message, I discovered that I had the same problem with Affinity Photo).

When I recently updated my GTX 1650 driver, I inadvertently selected the “Game ready” version which I don’t need. I usually install the “Studio” version. I do know that previously, I had no problem with the Game Ready version, though.

I downloaded the Studio version and reinstalled the driver : the “Game Ready” version remained installed. So, I uninstalled/deleted everything NVidia and reinstalled the “Studio” driver. Problem solved in the Nik Collection and in Affinity Photo.

So, this seems to be an NVidia problem but if you are using the “Game Ready” NVidia driver, now you know.

1 Like

Was OpenCL enabled for DPL in the"Game Ready" version?

Yes. All settings as usual.

there was @Mph2 whit this issue yesterday but no clue of why.

Not accurate enough : I had the same problem with Affinity just when launching it. Nothing to do with the Nik Plugins. The status window appeared in the upper left corner of the AP main window, there was a brief error message displayed that I had no time to read and Affinity Photo crashed almost immediately.

More about this.

It seems that the problem is caused by an incompatibility with the Asus GPU Tweak utility. I investigated further and found out that this tool might cause the problem I described under various circumstances.