Author Topic: 1.2.1 update won't install  (Read 791 times)

Claustral

  • Jr. Member
  • **
  • Posts: 26
1.2.1 update won't install
« on: July 20, 2018, 10:39:14 pm »
When I started Photolab 1.2.0 today I was offered an update to version 1.2.1. I said yes, it downloaded, I closed Photolab and ran the new file. This went through the usual Windows approval window and the questions about gathering user data and the one about installing the LR plug-in. However once it got to the main installation progress window, nothing happened. I let it "run" for 5 minutes but the progress bar didn't advance at all. Canceling didn't work. I had to restart to properly close the faulty process.
1.2.0 still runs correctly, so the problem isn't acute, but thought you'd like to know.

Bencsi

  • Hero Member
  • *****
  • Posts: 1616
Re: 1.2.1 update won't install
« Reply #1 on: July 21, 2018, 12:32:07 pm »
Hi Claustral,

Have a look into the "C:\Users\YOUR_USER_NAME\AppData\Local\Temp\photolab1_install_log.log" log file.
There is another file "photolab1_installer_bootstrap_log.log" which include the starting execution process only. If the last entry in the first file is: Installation success or error status: 0, the install went though correctly, meanwhile the actual state of the PC was not ready to start the app. In the past I also experienced several update can start errorles after a PC restart only.

Endre
Win7/64 PC, i7-3770, 3.9GHz, 24G RAM, Intel HD-4000 GPU, 27" calibrated LG monitor 1920*1080 px res. 82 DPI

Claustral

  • Jr. Member
  • **
  • Posts: 26
Re: 1.2.1 update won't install
« Reply #2 on: July 21, 2018, 03:22:57 pm »
The end of the Photolab install log says:
Action 20:34:30: CostFinalize. Computing space requirements
Action start 20:34:30: CostFinalize.
Action ended 20:34:30: CostFinalize. Return value 1.
Action 20:34:30: WelcomeDlg.
Action start 20:34:30: WelcomeDlg.
Action 20:34:30: WelcomeDlg. Dialog created
Info 2898. For WixUI_Font_Title textstyle, the system created a 'Tahoma' font, in 1 character set, of 14 pixels height.
Action 20:34:31: myLicenseAgreementDlg. Dialog created
Info 2898. For WixUI_Font_Normal__UL textstyle, the system created a 'Tahoma' font, in 0 character set, of 13 pixels height.
Action 20:34:35: InstallDirDlg. Dialog created
Action 20:34:37: WixUIValidatePath.
Action start 20:34:37: WixUIValidatePath.
Action ended 20:34:37: WixUIValidatePath. Return value 1.
Action 20:34:37: myFeaturesDlg. Dialog created
Action 20:34:52: VerifyReadyDlg. Dialog created
Action ended 20:34:54: WelcomeDlg. Return value 1.
Action 20:34:54: ProgressDlg.
Action start 20:34:54: ProgressDlg.
Action 20:34:54: ProgressDlg. Dialog created
Action ended 20:34:54: ProgressDlg. Return value 1.
Action 20:34:54: ExecuteAction.
Action start 20:34:54: ExecuteAction.
Action 20:39:36: CancelDlg. Dialog created
Action ended 20:40:19: ExecuteAction. Return value 2.
Action 20:40:19: UserExit.
Action start 20:40:19: UserExit.
Action 20:40:19: UserExit. Dialog created


The bootstrap log says:
Bootstrap - DxO PhotoLab - 2018-07-20 20:34:23
IsPlatformSupported => Major: 6
IsPlatformSupported => Minor: 2
IsPlatformSupported => Build: 9200
.NET version 4.7.1 should be supported. Initializing installation...
.NET selected version is already installed.
Initializing PhotoLab installation.
InstallProduct => Run command: msiexec /i "C:\Users\Owner\AppData\Local\Temp\WiXInstaller_photolab1.msi" /log "C:\Users\Owner\AppData\Local\Temp\photolab1_install_log.log"


I have tried installing directly after a restart (in fact that's the attempt iterated in the files above), but no success. As you can see in the install log I pressed Cancel after 5 minutes. Perhaps I should be more patient? It's never taken anything like 5 minutes to show progress in the past however.

Claustral

  • Jr. Member
  • **
  • Posts: 26
Re: 1.2.1 update won't install
« Reply #3 on: July 21, 2018, 03:55:28 pm »
I did try again, with a fresh download and with a newly restarted PC. It failed too. This time however I was patient and after about 15 minutes a dialogue box opened saying the update had failed.
However in the bootstrap log file there is data suggesting that I cancelled the installation, which I definitely didn't today. So that seems to be the problem - somehow the installer is receiving a user cancellation, even with the user not even being present. Here are the relevant lines from the bootstrap log:

Action 15:29:04: ProgressDlg.
Action start 15:29:04: ProgressDlg.
Action 15:29:04: ProgressDlg. Dialog created
Action ended 15:29:04: ProgressDlg. Return value 1.
Action 15:29:04: ExecuteAction.
Action start 15:29:04: ExecuteAction.
User cancelled installation.
C:\Users\Owner\AppData\Local\Temp\WiXInstaller_photolab1.msi
Action ended 15:36:32: ExecuteAction. Return value 2.
Action 15:36:32: UserExit.
Action start 15:36:32: UserExit.
Action 15:36:32: UserExit. Dialog created
Action ended 15:43:52: UserExit. Return value 2.
Action ended 15:43:52: INSTALL. Return value 2.

Claustral

  • Jr. Member
  • **
  • Posts: 26
Re: 1.2.1 update won't install
« Reply #4 on: July 21, 2018, 04:11:35 pm »
 8) Solved. I tried again, but with the cloud back-up service paused (Code 42 CrashPlan) and it ran (eventually) successfully. It did take a while to start but then all progressed as per usual. My suspicion is that CrashPlan locked some critical file as it was backing it up and that caused the install to fail.
Photolab is now running at 1.2.1.

 

photography