Author Topic: My dxo one cannot work  (Read 1562 times)


  • Newbie
  • *
  • Posts: 2
My dxo one cannot work
« on: April 01, 2018, 11:25:47 am »
My dxo one can’t power up again
It tries.  The dxo logo comes up in the OLED Screen, but only for a fraction of a second,  then nothing. 

This is true in every configuration I have tried (connected to iPhone, and not, with sd card installed, and not, connected to my PC, and not).

For all practical purposes it has bricked itself.

This has all happened AFTER a week long trip to the UK and AFTER downloading a raft of pictures.

I would like to use my camera again.

I have submitted a support request (#110390), but I've heard nothing after one and half days, and no idea how long it will be.


  • Administrator
  • Jr. Member
  • *****
  • Posts: 9
Re: My dxo one cannot work
« Reply #1 on: May 18, 2018, 02:43:02 pm »
Sorry for th late answer. Please try those steps:

1/ Remove the memory card from the DXO One 
2/ Connect to mains power - this should initialize the camera
3/ Re-insert the memory card, all is supposed to work successfully

Hope this can help.


  • Newbie
  • *
  • Posts: 1
Re: My dxo one cannot work
« Reply #2 on: June 02, 2018, 11:12:24 pm »
did you try reseting the camera?
you said you tried everything ! must have missed the reset.
these are some instructions from dxo suport how to reset the camera
Plug your DxO ONE into a charger or laptop, and make sure the camera is ON (lens cap open).
With the DxO ONE plugged in, use a paperclip to depress the reset switch. You'll feel the change in pressure as you reset and let go (you do not need to hold the reset switch for any particular length of time).
Turn off the camera by closing the lens cover.
Restart your camera by reopening the lens cover.
NOTE: Be sure to press the reset switch and not a screw inside the microSD card or USB Connector slots.
ive been using my dxo one for like a year now i got no complaints the camera works really good
and i travel alot!